1

Closed

Unable to create Ruby on Rails project using Visual Studio 2010, error: can't convert NilClass into String

description

VS2010 shows this is the output window:
 
Creating Rails app RoR in D:/delete/RoR ...
Installing missing gems: rails (3.0.1), activerecord-sqlserver-adapter (3.0.2)
can't convert NilClass into String
WARNING: You don't have C:/Users/pb/.gem/ironruby/1.9.1/bin in your PATH,
  gem executables will not run.
can't convert NilClass into String0 gems installed
 
 
In the file system, the only file created is the solution (.sln) file
Closed Jul 28, 2011 at 6:15 PM by jimmysch

comments

TomasMatousek wrote Feb 7, 2011 at 1:55 AM

This should be fixed in 1.1.2. Have you tried building from source? If not we'll release 1.1.2 soon so let us know if it works.

tacoman667 wrote Feb 7, 2011 at 7:08 PM

I just built from fresh fetch and got errors building ipy but IronRuby.msi built. I installed no problem. I still get the NilClass error when trying to install rails. This was an issue introduced in 1.1.1. I never had this issue in 1.1 or below.

Are there any dependencies IR requires pre-installed or will having other ruby versions installed cause issues like this?